在php7.1下编译安装swoole扩展始终报错:

libtool: Version mismatch error. This is libtool 2.4.2 Debian-2.4.2-1ubuntu1, but the
libtool: definition of this LT_INIT comes from libtool 2.4.6b.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2 Debian-2.4.2-1ubuntu1


折腾许久,找到答案:

autoreconf --force --install

然后再运行 ./configure,,make all, sudo make install。

参考:https://github.com/plashchynski/libdssl/issues/3

autoreconf用法c参看:http://man.he.net/man1/autoreconf